SNES9x 1.53 for Mac question

If you're having problems with Snes9x, or think you've found a bug, this is the place to be.
Post Reply
Snes9x White Belt
Posts: 1
Joined: Sun Oct 01, 2023 9:15 pm

SNES9x 1.53 for Mac question

Post by izlude »

Hi all, I'm coming from the site Macintosh Garden. They had snes9x v1.43 listed for a while, but during my latest visit, noticed v1.53!!

Firstly, I couldn't settle with 1.43 because it has that mouse issue where if you play something like the fly swatter game in Mario Paint (fast erratic movement), the cursor stops mid screen, believing it has hit the far edge when it hasn't. Moving the mouse to the other side and then back temporarily fixes it until it happens again.

I'd love to try 1.53 to see if this issue was fixed (as I have experienced, the latest 1.6 versions have indeed fixed this, so hoping it goes as far back as 1.53). It's supposed to be a universal binary that runs on both PPC and Intel versions of OS X 10.4, but so far, I can't get it to work. :(

Tried it on my G3s and G4 MDD, all running 10.4.11 PPC of course, the snes9x icon just appears in the dock and then disappears and doesn't launch. The Terminal states "incompatible CPU-subtype". I've tried all downloads of this, even 1.52 for the heck of it, they all do the same thing. What can I do to get things working?
Snes9x Green Belt
Posts: 444
Joined: Tue May 03, 2011 2:35 pm

Re: SNES9x 1.53 for Mac question

Post by odditude »

all I could find is some discussion in the 1.52 release thread: viewtopic.php?t=4542&start=40
Post Reply