Trouble with Superscope command line

If you're having problems with Snes9x, or think you've found a bug, this is the place to be.
Post Reply
YMI
Snes9x White Belt
Posts: 3
Joined: Thu Dec 27, 2007 7:06 pm

Trouble with Superscope command line

Post by YMI »

Hello,

I'm trying to run snes9x with command line (I found the list on this message board)

I just try to get the superscope working when the emulator start without having to go to any configuration menu to change settings.

here is the command line I type

Snes9x -port2 superscope Gamename.smc

the game run itself, but the superscope is not working. I tryed other command, and they work. Only the -port# command dont seem to work.

Anyone know how to make this command line working or know another way to make the superscope active at the start of snes9x?

Thanks
Deathlike2
Snes9x Brown Belt
Posts: 1153
Joined: Mon Jan 10, 2005 6:34 am

Post by Deathlike2 »

If you are using the latest version of Snes9x (1.51), what you can do is add an NSRT header to the ROM, so Snes9x automatically uses the mouse for your Superscope game. You will have to obtain NSRT though...
YMI
Snes9x White Belt
Posts: 3
Joined: Thu Dec 27, 2007 7:06 pm

Post by YMI »

I tryed NSRT, but it's not a good solution.

The game I try to run is Tin Star. NSRT detect it as a Gamepad/mouse game. so, both are activated, and gamepad is on default, not mouse.

Then, there are those Multipad games I would also like to activate with the -Port# command line, and NSRT doesnt detect this game divice.

I tryed older version of Snes9x, but -port# doesnt seem to work either (am I typing it wrong?).

I also tryed different Snes9x folders for different configuration, but all the special game device are always deactivated at a new start of snes9x.
Deathlike2
Snes9x Brown Belt
Posts: 1153
Joined: Mon Jan 10, 2005 6:34 am

Post by Deathlike2 »

You're supposed to add the NSRT header, not the regular header.

Snes9x AFAIK doesn't save the device used for the game.. which is intentional for obvious reasons. Some regular games that don't use such devices won't start properly when detected.

If you are ultimately concerned, write a script/batch file to run your special device games.

It doesn't help that you haven't mentioned what version of Snes9x you are using in all of this.
YMI
Snes9x White Belt
Posts: 3
Joined: Thu Dec 27, 2007 7:06 pm

Post by YMI »

I'm using the last version I suppose (1.51) and I tryed older version also.

I have added a NSRT header. But like I said, the game TIN STAR is detected as an GAMEPAD/MOUSE game, so, the game pad is ON by default, and I would like the MOUSE or SUPERSCOPE as default. I would also like to have some game with the multitap activeted at the start of the emulator, And the NSRT header does not detect this device.

If by batch you mean the use of command line in a .bat file, the problem is still the same, since I am still unable to make the -port# command line work. the same problem occur when trying to use a front end, since it's command line based.

I'm able to make all the other command lines work, it's only the -port# command line that dont seem to work. wathever parameter I used, there is no mouse/superscope/multipad activated.
nooch
Snes9x White Belt
Posts: 2
Joined: Fri Aug 06, 2010 7:24 pm

Post by nooch »

deleted
Last edited by nooch on Tue Aug 17, 2010 12:43 am, edited 1 time in total.
nooch
Snes9x White Belt
Posts: 2
Joined: Fri Aug 06, 2010 7:24 pm

Post by nooch »

I hate to bump up an old topic, but I am still having the same problem as the original poster. I noticed it seems people are doing updates on the software and if another update is done, please fix this error. I made an arcade cab and would like to have my actlabs guns automatically work when the gun game is loaded... using the command line.

However, when I try what the original poster did, I get the same problem. Game loads, just not defaulted to port2 being superscope.

Thanks for any help!
-Nooch
Deathlike2
Snes9x Brown Belt
Posts: 1153
Joined: Mon Jan 10, 2005 6:34 am

Post by Deathlike2 »

Well, the problem with the original poster's problem is that "Tin Star" is not a Super Scope game. In fact, it is a SNES mouse game. The whole NSRT header thing works ONLY if the game supports/requires the correct special device for that system.

My suggestion is that you post what game that happens to be and use NSRT to add its special header. The reality is that you cannot add Superscope or whatever special device to a game that does not natively use it... like the SNES Mouse to a game like Ogre Battle.
Continuing FF4 Research...
Runzelblunze
Snes9x White Belt
Posts: 4
Joined: Wed Jun 12, 2013 8:32 pm

Re: Trouble with Superscope command line

Post by Runzelblunze »

Hi!

Also having the same problem as the original poster:
Games I'm trying to run are battle clash and bazooka blitzkrieg
The SW Version is 1.53
I run it like this
"I:\HyperSpin\Emulators\nintendo - super nintendo entertainment system\snes9x\snes9x" -port2 superscope "i:\HyperSpin\Roms\Nintendo - Super Nintendo\Bazooka Blitzkrieg (USA).sfc"
and get the message
"Cannot select SNES Superscope: SuperScopeMaster disabled"
As soon as the Emulator is running, I can select Super Scope though.
Also I found some options for the snes9x.conf like this one:
SuperscopeMaster = TRUE
doesn't work with FALSE either...
If I write the conf option in camel case like in the error message with a capital S, it doesn't change anything...
Runzelblunze
Snes9x White Belt
Posts: 4
Joined: Wed Jun 12, 2013 8:32 pm

Re: Trouble with Superscope command line

Post by Runzelblunze »

Since you suggested something with nsrt headers I tried that as well... no idea if I did it right though. The nsrt frontend says port2 is super scope but it's like launching the game without specifying the device in port 2. Do I have to save that header somewhere? Do I have to tell snes9x to use the header information?
I don't really like messing with headers I know nothing about. I think the cli parameters would be super easy to use and the .conf file is even better!
I also want to use it in an emulator frontend and I think using multiple snes directories, each with it's own config would be easiest.
A multitap config, a mouse/trackball config, a superscope config and so on
Runzelblunze
Snes9x White Belt
Posts: 4
Joined: Wed Jun 12, 2013 8:32 pm

Re: Trouble with Superscope command line

Post by Runzelblunze »

mou, why can't I edit my posts...

I found another thing:

case CTL_SUPERSCOPE:
if (!Settings.SuperScopeMaster)
{
S9xMessage(S9X_CONFIG_INFO, S9X_ERROR, "Cannot select SNES Superscope: SuperScopeMaster disabled");
break;
}


here it's also camel case, but if I use camel case in the .conf file, that line will be removed on snes9x startup.

Also: tin star is a gamepad/mouse/super scope game
If you start it with super scope active, you even get a fancy calibration... thingy
User avatar
OV2
Official Win32 Porter/Dev
Posts: 679
Joined: Thu Aug 30, 2007 10:15 pm

Re: Trouble with Superscope command line

Post by OV2 »

It's currently not possible in the win version. I'll try to create a new testversion this weekend that supports setting controllers from the command line.
User avatar
OV2
Official Win32 Porter/Dev
Posts: 679
Joined: Thu Aug 30, 2007 10:15 pm

Re: Trouble with Superscope command line

Post by OV2 »

Here's an updated version where the command line controller options should work: snes9x_testbuild_16062013.zip
Runzelblunze
Snes9x White Belt
Posts: 4
Joined: Wed Jun 12, 2013 8:32 pm

Re: Trouble with Superscope command line

Post by Runzelblunze »

Thank you so much! Both commandline and preferences file work perfectly! This is just what I needed!
Post Reply