.smv play and record not working after compile

This is for people involved in the developement of Snes9x, or SNES emulators in general.
BUG REPORTS BELONG IN TECH SUPPORT/BUG TRACKING!

Moderator: Ryan

Post Reply
l3m35
Snes9x White Belt
Posts: 2
Joined: Sat Jul 11, 2015 5:42 pm

.smv play and record not working after compile

Post by l3m35 » Fri Jul 17, 2015 8:04 pm

Hello again (I've asked the same on GitHub, but with no response, so decided to try here).

Is there any reason in special, when compiling, that may cause playing .smv files to fail? My debug version of Snes9x seems to be ok recording (the message and frame count appears), but it's impossible to play the file/movie later (message: The movie file is corrupted or in wrong format).

And more: it seems to don't be playing and recording. I've recorded a movie in stable .exe releases, and the smv didn't worked on my Snes9x-debug.exe. The debug output shows:

Code: Select all

Invalid parameter passed to C runtime function.
Invalid parameter passed to C runtime function.
Invalid parameter passed to C runtime function.
...when trying to read .smv files.

Note: please delete my previous topic about how to compile, since I managed to do it already.

User avatar
OV2
Official Win32 Porter/Dev
Posts: 645
Joined: Thu Aug 30, 2007 10:15 pm

Re: .smv play and record not working after compile

Post by OV2 » Sat Jul 18, 2015 1:04 pm

You could try to determine which line causes the invalid parameter output by stepping through. It should be somewhere in S9xMovieGetInfo.

l3m35
Snes9x White Belt
Posts: 2
Joined: Sat Jul 11, 2015 5:42 pm

Re: .smv play and record not working after compile

Post by l3m35 » Sat Jul 18, 2015 7:22 pm

Thank you, I had no luck with it.

Code: Select all

First-chance exception at 0x76E74598 in snes9x-debug.exe: Microsoft C++ exception: long at memory location 0x0018FC58.
...followed by the invalid parameters. But I'll keep trying.

Post Reply