Snes9x 1.52 is now dead due to Snes9X 1.53 being out

This is for people involved in the developement of Snes9x, or SNES emulators in general.
BUG REPORTS BELONG IN TECH SUPPORT/BUG TRACKING!

Moderator: Ryan

User avatar
OV2
Official Win32 Porter/Dev
Posts: 644
Joined: Thu Aug 30, 2007 10:15 pm

Post by OV2 » Fri Jan 15, 2010 11:08 pm

the_randomizer wrote:Now that the source code is released, I wonder if anyone will be willing to port it over to the Wii/Gamecube.....Not that I'm giving any hints, mind you.
AFAIK the snes9x-gx author is working on upgrading his port.

User avatar
King Of Chaos
Snes9x White Belt
Posts: 6
Joined: Mon Feb 20, 2006 2:01 am

Post by King Of Chaos » Sat Jan 16, 2010 12:21 am

Awesome, I can then play Mighty Morphin Power Rangers: The Fighting Edition without issue on the Wii. :P

the_randomizer
Snes9x Orange Belt
Posts: 222
Joined: Sat Oct 17, 2009 4:18 am

Post by the_randomizer » Sat Jan 16, 2010 12:27 am

OV2 wrote: AFAIK the snes9x-gx author is working on upgrading his port.
Glad to hear that. To think I can play FF6 on the wii with hardware-perfect sound!
Lisa: "I hope you all know you're sponsoring a murderous pirate!"
Sponsor: "A pirate!!? Well, that's hardly the image we need for Long John Silvers!"

badinsults
Snes9x White Belt
Posts: 29
Joined: Sat Jan 16, 2010 10:09 am

Post by badinsults » Sat Jan 16, 2010 10:22 am

First off, thanks for the release. I have always preferred zsnes over snes9x, but with this release I have switched. The sound is great, and the GTK interface is perfect.


Second off, I have had some issues where snes9x would run very slowly after loading a ROM. I suspect this is a sound issue, but I cannot reproduce it exactly. I haven't ran into it with the Pulseaudio driver, but I did with OSS, SDL and ALSA. I am running Ubuntu 9.10, 64-bit on this computer

algerng
Snes9x White Belt
Posts: 1
Joined: Sat Jan 16, 2010 6:26 pm

Post by algerng » Sat Jan 16, 2010 6:28 pm

Thanks a million for the great work!

I hope the DSP-3 will be fully emulated soon.

smoki
Snes9x White Belt
Posts: 2
Joined: Sat Jan 16, 2010 9:41 pm

Post by smoki » Sat Jan 16, 2010 9:48 pm

Hi, is this right place for bugs:)? 'REAL MONSTERS' also have sound? problem/regression in 1.52 and that tends to freeze emulation sooner or later.

User avatar
OV2
Official Win32 Porter/Dev
Posts: 644
Joined: Thu Aug 30, 2007 10:15 pm

Post by OV2 » Sat Jan 16, 2010 11:51 pm

The (hopefully) last fix for this release corrects the issue reported by creaothceann and a few issues I've encountered myself:
http://download.sessionclan.de/overfien ... 2.fix4.zip

I've also made a special win9x build for sjyune:
http://download.sessionclan.de/overfien ... 32.w9x.zip

And here is a list of the fixes:

Code: Select all

fix4:
  -selecting "display messages before applying filters" prior to loading any rom could cause a crash
  -hq4x and simple4x did not work correctly in DirectDraw and 32bit modes
  -selecting filters with different scales for normal/hi-res modes caused incorrect message scaling
  -the rom information window was always disabled
fix3:
  -avi recording crashed on < vista
  -delete key mapping did not work after emulator restart
fix2:
  -parts of the window stopped updating when previously covered by other windows (only in d3d mode)
fix1:
  -display corruption in Super Metroid/Donkey Kong Country/... due to compiler optimization
Sorry about all the small bugs - it seems I focused too much on the sound changes and thus missed the rest...

sjyune
Snes9x White Belt
Posts: 23
Joined: Mon Jul 24, 2006 12:19 am

Post by sjyune » Sun Jan 17, 2010 10:24 am

OV2 !

Thanks millions for this 'personal' build...
works just fine except rom dialogue box doesn't pop-up so i have to use 'recent rom' menu to select rom image..
Is this Win9x specific problem or official bug ?
just curious...

anyway, i really appriciate it !! :wink:

Tukuyomi
Snes9x White Belt
Posts: 32
Joined: Mon May 24, 2004 4:14 pm
Location: France

Post by Tukuyomi » Sun Jan 17, 2010 1:06 pm

sjyune wrote:otherwise it shouldn't be named 'Snes9X'
Btw, it wasn't named after the Win9x at first.
http://snesemu.black-ship.net/misc/snes ... story.html
(the link in the first line is now dead :/ but you get the quick story at least^^)
=)

User avatar
OV2
Official Win32 Porter/Dev
Posts: 644
Joined: Thu Aug 30, 2007 10:15 pm

Post by OV2 » Sun Jan 17, 2010 1:36 pm

sjyune wrote:OV2 !

Thanks millions for this 'personal' build...
works just fine except rom dialogue box doesn't pop-up so i have to use 'recent rom' menu to select rom image..
Is this Win9x specific problem or official bug ?
just curious...

anyway, i really appriciate it !! :wink:
No idea why this doesn't work - try enabling the "Custom ROM Open Dialog" in Options->Settings.

TigerG3
Snes9x White Belt
Posts: 4
Joined: Sun Jan 17, 2010 2:40 pm

Post by TigerG3 » Sun Jan 17, 2010 2:46 pm

Hi,
but this new version does not work on G3 systems running Mac OS X Tiger?

Sincerely

User avatar
zones
Official Mac OSX Porter/Dev
Posts: 908
Joined: Sat May 15, 2004 11:58 pm
Location: Japan

Post by zones » Sun Jan 17, 2010 3:07 pm

TigerG3 wrote:Hi,
but this new version does not work on G3 systems running Mac OS X Tiger?

Sincerely
At least works on PowerBook G3 10.3.9, PowerBook G4 10.5.8 and MacBook 10.6.2.

TigerG3
Snes9x White Belt
Posts: 4
Joined: Sun Jan 17, 2010 2:40 pm

Post by TigerG3 » Sun Jan 17, 2010 4:13 pm

zones wrote: At least works on PowerBook G3 10.3.9, PowerBook G4 10.5.8 and MacBook 10.6.2.
This is the my log file (iMac G3):

Code: Select all

**********

Host Name:      Computer
Date/Time:      2010-01-16 18:02:09.183 +0100
OS Version:     10.4.11 (Build 8S165)
Report Version: 4

Command: Snes9x
Path:    /Volumes/HD/Applications/Snes9x/Snes9x.app/Contents/MacOS/Snes9x
Parent:  WindowServer [61]

Version: 1.52 (1.52)

PID:    320
Thread: Unknown

Link (dyld) error:

incompatible cpu-subtype
The version 1.51 works perfectly!

sjyune
Snes9x White Belt
Posts: 23
Joined: Mon Jul 24, 2006 12:19 am

Post by sjyune » Sun Jan 17, 2010 9:59 pm

OV2 wrote:
sjyune wrote:OV2 !

Thanks millions for this 'personal' build...
works just fine except rom dialogue box doesn't pop-up so i have to use 'recent rom' menu to select rom image..
Is this Win9x specific problem or official bug ?
just curious...

anyway, i really appriciate it !! :wink:
No idea why this doesn't work - try enabling the "Custom ROM Open Dialog" in Options->Settings.

thanks again for the tip, that surely fixed the problem...
it now works just as before ! :P

sjyune
Snes9x White Belt
Posts: 23
Joined: Mon Jul 24, 2006 12:19 am

Post by sjyune » Sun Jan 17, 2010 10:28 pm

i tested some games ,now it sounds great
APU releated bugs are all gone...good works guys !!

though i see there are still old GFX bugs unchanged

SD Gundam G-Next (map glitch)
Wally wo Sagase! / Where is wally (dialogue box glitch)
Funaki Masakatsu Hybrid Wrestler - Tougi Denshou (intro glitch on top)
Jumping Derby (time attack mode glitch or SA1 bug ?)

i hope someday you guys replace GPU/SA1 emulation with Byuu's Bsnes core as all these GFX bugs are not present on Bsnes...
Last edited by sjyune on Sun Jan 17, 2010 10:31 pm, edited 1 time in total.

guelfo
Snes9x White Belt
Posts: 1
Joined: Sun Jan 17, 2010 10:24 pm

Post by guelfo » Sun Jan 17, 2010 10:30 pm

The 4fix is runningp perfectly here. I was having the same "slow" rom problem but it's easy to fix by changin the window in the option menu.

xaudio2 is now workingg great!

Thanks!

User avatar
gocha
Snes9x Yellow Belt
Posts: 64
Joined: Sun Dec 30, 2007 12:14 am
Location: Japan, Nagoya

Post by gocha » Mon Jan 18, 2010 12:42 am

OV2 wrote:
sjyune wrote:OV2 !

Thanks millions for this 'personal' build...
works just fine except rom dialogue box doesn't pop-up so i have to use 'recent rom' menu to select rom image..
Is this Win9x specific problem or official bug ?
just curious...

anyway, i really appriciate it !! :wink:
No idea why this doesn't work - try enabling the "Custom ROM Open Dialog" in Options->Settings.
http://edn.embarcadero.com/jp/article/22880
http://support.codegear.com/jp/article/35754

Edit: by the way, is there a diff of your win32 fix, OV2?

User avatar
OV2
Official Win32 Porter/Dev
Posts: 644
Joined: Thu Aug 30, 2007 10:15 pm

Post by OV2 » Mon Jan 18, 2010 1:27 am

Thanks again.

Here are diffs from 1.52 to fix4:
http://download.sessionclan.de/overfien ... .diffs.zip

User avatar
Deathbringer
Snes9x White Belt
Posts: 4
Joined: Mon Jan 18, 2010 2:09 am
Location: The Land of the Dead

Hello

Post by Deathbringer » Mon Jan 18, 2010 2:20 am

Hello, I'm new here, but has been years that I play video games and emulators.


Thanks for the emulator, one of the best for sure.


I downloaded the fix 4 from 1.52 ver. and I note that another option that always is unchecked is Fullscreen (in display settings) and the screenshots I take looks crashed or something. It's strange because when I open the screenshot with ACDSee Viewer it looks good, but In the windows viewer looks messed up.

Thanks in advance and keep the good work!

Locked