GTK Version Fails; Plain Snes9x Does Not (BS-X/Satellaview)

If you're having problems with Snes9x, or think you've found a bug, this is the place to be.

Moderator: Ryan

Post Reply
User avatar
Wii
Snes9x White Belt
Posts: 3
Joined: Thu Nov 02, 2017 5:28 pm

GTK Version Fails; Plain Snes9x Does Not (BS-X/Satellaview)

Post by Wii » Thu Nov 02, 2017 7:07 pm

Hello. I have succeeded in running some BS-X/Satellaview games using Snes9x 1.54.1 on Arch Linux, as per instructions in unix/docs/readme_unix.html. Thank you for maintaining Snes9x. It is a great piece of software.

I generally use Snes9x's GTK front-end (snes9x-gtk), as the plain executable (snes9x) spawns screen-sized windows with -fullscreen, instead of actually running fullscreen. In addition, the video image is not stretched to full size.

Today, however, I noticed the plain executable is capable of running a few BS-X/Satellaview games that the GTK version is not. When snes9x-gtk attempts to run these games, it produces a black screen and no sound. No errors appear on the command line. I thought perhaps an option enabled in snes9x.xml might have been the culprit (as only snes9x-gtk reads this), but deleting that file and running snes9x-gtk results in the same black screen.

Any insight would be appreciated.

User avatar
Wii
Snes9x White Belt
Posts: 3
Joined: Thu Nov 02, 2017 5:28 pm

Re: GTK Version Fails; Plain Snes9x Does Not (BS-X/Satellavi

Post by Wii » Fri Nov 03, 2017 2:45 am

Two such titles are BS Zelda no Densetsu Remix (J) and BS Fire Emblem Akaneia Senki 1 - Palace Kanraku (J). Please private message me, if you require further explanation.

User avatar
hobbledehoy899
Snes9x White Belt
Posts: 3
Joined: Wed Nov 08, 2017 7:23 pm
Location: Linux 4.13.12-1-ARCH

Re: GTK Version Fails; Plain Snes9x Does Not (BS-X/Satellavi

Post by hobbledehoy899 » Wed Nov 08, 2017 7:31 pm

Have you seen if the games will run on a "1.55" binary compiled from the master source branch?

User avatar
Wii
Snes9x White Belt
Posts: 3
Joined: Thu Nov 02, 2017 5:28 pm

Re: GTK Version Fails; Plain Snes9x Does Not (BS-X/Satellavi

Post by Wii » Sun Nov 12, 2017 4:25 pm

Thanks for the tip. I had high hopes, as I didn't realize there was a newer version. Is it official? Snes9x's web master should consider mentioning something on the front page or at least the news section.

Sadly, the game still did not run. The only difference was the following error message (which appeared three times):

Code: Select all

Unable to find msu file /home/user/.snes9x/patch/BS Fire Emblem Akaneia Senki 1 - Palace Kanraku (J).msu1.
The game still runs fine with regular ("unix") Snes9x. I'll compare config/make files and see if I can't pinpoint a cause.

User avatar
hobbledehoy899
Snes9x White Belt
Posts: 3
Joined: Wed Nov 08, 2017 7:23 pm
Location: Linux 4.13.12-1-ARCH

Re: GTK Version Fails; Plain Snes9x Does Not (BS-X/Satellavi

Post by hobbledehoy899 » Sun Nov 12, 2017 6:47 pm

Yes, that is the official master source branch for Snes9x.

User avatar
BearOso
Official GTK/Linux Porter/Dev
Posts: 450
Joined: Tue Oct 02, 2007 12:50 am

Re: GTK Version Fails; Plain Snes9x Does Not (BS-X/Satellavi

Post by BearOso » Tue Nov 21, 2017 6:15 pm

I was able to get Fire Emblem to run on GTK+. All I needed was to have the BS-X.bios file in the same directory as the ROM image. I don't have a version of BS Zelda like you specify.

Post Reply