It is currently Thu Sep 20, 2018 3:43 am

All times are UTC




Post new topic Reply to topic  [ 3 posts ] 
Author Message
PostPosted: Thu Feb 22, 2018 12:24 am 
Offline
Snes9x White Belt

Joined: Wed Feb 21, 2018 11:58 pm
Posts: 3
Reproduce:100%
Open Snes9x 1.54.1.
Open any ROM.
Goto Sound -> Settings
Check "Mute Sound"

The audio now becomes a continuous garbled loop of stuttering.
It does not mute the sound.

OS: Windows 8.1 x64
SNES9x: 1.54.1 (For Windows)


Top
 Profile  
Reply with quote  
PostPosted: Thu Feb 22, 2018 4:22 am 
Offline
Snes9x White Belt

Joined: Wed Feb 21, 2018 11:58 pm
Posts: 3
I forgot to mention the Sound Driver used is XAudio2.
When I set it to Snes9x DirectSound the mute option works.
Strange part is, when in Snes9x DirectSound there is studdering if I click on one of the menuItems.
In other words, the application goes to an onPause() state but the sound continues studdering.


Top
 Profile  
Reply with quote  
PostPosted: Thu Feb 22, 2018 1:16 pm 
Offline
Official Win32 Porter/Dev
User avatar

Joined: Thu Aug 30, 2007 10:15 pm
Posts: 627
Did you try 1.55 or the most recent testbuild?


Top
 Profile  
Reply with quote  
Display posts from previous:  Sort by  
Post new topic Reply to topic  [ 3 posts ] 

All times are UTC


Who is online

Users browsing this forum: Baidu [Spider] and 17 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
Jump to:  
Powered by phpBB® Forum Software © phpBB Group